16. September 2014

Shift-R improves the quality of this image. CTRL+F5 reloads the whole page.

Wenn ich größere Webseiten besuche, schalte ich meistens meine Internet-Verbindung über die UMTS Flatrate von E-Plus ein. Vor ein paar Tagen ist mir aufgefallen, das die JPEG-Grafiken z.T. deutliche Kompressions-Artefakte zeigen. Wenn man mit dem Cursor über der Grafik steht, erscheint zusätzlich im normalen Titel der Text “Shift-R improves the quality of this image. CTRL+F5 reloads the whole page.” Zuerst dachte ich, dass Opera mir einen Streich spielt bzw. das es ein Feature der neuen Version (9.0 Preview 1) ist. Opera ist allerdings nicht der Schuldige, sondern E-Plus: die Bilder werden transparent neu komprimiert und die entsprechenden HTML-Tags geändert. Ein neu laden der Seite liefert dann tatsächlich die Original-Version der Bilder aus. Meine Tests zeigen, das die Dateigröße der komprimierten Version bei ca. 1/3 bis 2/3 der Originalgröße liegt, was leider zu deutlichen Qualitätseinbußen, insbesondere bei kleineren Bildern führt.

Einerseits führt die transparente Komprimierung zu einem geringeren Datenvolumen und damit auch zu einer höheren Geschwindigkeit, andererseits würde ich über die Verwendung eines solchen ‘Features’ aber gern selbst entscheiden können oder wenigstens einen Hinweis darauf auf diese Praxis erhalten. Gerade bei Seiten, wo man die Bilder wirklich sehen möchte, muss man diese jetzt zweimal laden, was leider Zeit kostet und aufwendig ist.

Update vom 23.10.2010: Vodafone-Nutzer können die Einstellung jetzt permanent unter http://performance.vodafone.de ändern.

Comments

  1. Mario Jähn says:

    Ich habe seit kurzem das selbe Problem und bin seither ständig auf Fehlersuche. Leider ohne Erfolg. Woher wissen Sie, dass die Ursache bei Eplus zu finden ist? Gibt es wirklich keine Möglichkeit diese Einstellung rückgängig zu machen? MfG Mario Jähn

  2. Ich bin ziemlich sicher, das die Ursache bei E-Plus liegt, denn wenn ich die UMTS-Verbindung ausschalte und meine normale Netzverbindung nutze, erscheinen alle Bilder im Original ohne entsprechenden Hinweis. Ich warte noch auf einen Rückruf der E-Plus IP-Hotline wegen meinem Problem mit den Verbindungsabbrüchen, dort werde ich fragen, ob man das abschalten kann.

  3. Mario Jähn says:

    Hallo Herr Kämmerer,

    ich habe herausgefunden, dass nach jedem Start der Eplus Online Connect Software von dieser die Einstellungen im System veranlasst werden. Ich habe deshalb meinen Rechner mit dem Ccleaner gereinigt und starte Eplus über ”Start->Verbinden mit”. Hier werden die Einstellungen belassen und alle Bilder in normaler Auflösung geladen. Was den versprochenen Rückruf von Eplus angeht mache ich Ihnen wenig Hoffnung das dieser erfolgt. MfG Mario Jähn

  4. Diese Beobachtungen kann ich bestätigen: Baut man die Verbindung über den Mobilfunknetzassistenten auf, wird scheinbar der transparente Proxy aktiviert. Ob das durch eine Umleitung auf einem Proxy im lokalen System oder durch Konfiguration der Verbindung direkt im Handy passiert, konnte ich noch nicht herausfinden. Die Lösungsmöglichkeit ist, ohne den Assistenten zu verbinden. Auf den Rückruf werde ich noch 1-2 Tage warten und wenn dieser nicht erfolgt werde ich wohl eine Presse-Anfrage draus machen müssen, die dann Erfahrungsgemäß schneller beantwortet werden.

  5. Mario Jähn says:

    Vielen Dank für die Antwort! Ein weiteres Problem was vor etwas längerer Zeit in Verbindung mit Eplus aufgetaucht ist, ist die Tatsache, dass bestimmte Server nicht mehr angesteuert werden können. Unter anderem benutze ich eine Börsensoftware, welche mit einem Server bei meinem Broker online verbunden ist und mir permanent per Livestream realtime Börsenkurse zur Verfügung stellt.
    Leider ist dies nicht mehr möglich, weil die Software ständig versucht den Server anzusteuern es aber zu keiner Verbindung kommt. Der Helpdesk meines Brokers kam nach langer Fehleranalyse zu dem Ergebnis, dass es an meinen Internet Provider liegen muss. Und tatsächlich gibt es auch beim Benutzen eines normalen analogen Modems keine Probleme und alles funktioniert wunderbar. Leider häufen sich die Probleme dieser Art, was sehr schade ist, denn eigentlich war ich mit der UMTS Flatrate sehr zufrieden.

  6. Vielen Dank Herr Jähn!
    Ich bin bald verrückt geworden. Ein ewiges hin und her. Aber Ihre Lösung scheint es erstmal gebracht zu haben. Den Anruf bei E-Plus kann man sich im übrigen wirklich sparen. Ausser WIRKLICH qualifiziertem Personal und viel vergeudeter Zeit, erreicht man leider nichts.
    MfG

  7. Was für Geschwindigkeiten erreicht ihr in Jena mit UMTS?
    Ich wohne direkt an der Stadtkirche und bekomme maximale DL-Raten von 10-12kbit…

  8. Egon, in Jena konnte ich mit UMTS recht oft knapp 40kb/s (ftp-Download) messen. Allerdings brechen je nach Tageszeit die Raten auf das Minimum von knapp 12kb/s ein. Der UMTS-Sender auf dem Intershop-Tower ist scheinbar immer öfters überlastet.

  9. Ich habe folgenden Test genutzt: http://verivox.de/Internet/Netmeter/index.asp?j=t&Partner_ID=

    Hab hier ein Motorola E1000 über Bluetooth und komme beim besten WIllen nicht über 12kbit…

  10. Der Test zeigt bei mir Werte, die nicht stimmen können. Besser ist es, einfach einen größeren Download zu nehmen und dann abzuwarten, auf welcher Geschwindigkeit der sich einpegelt. Die Ping-Zeiten sind bei UMTS zu lang, um innerhalb dieser wenigen Sekunden, die der Test läuft, etwas aussagen zu können.

  11. handyman says:

    Hallo, mir ist das Problem mit den Bildern und CTRL+F5 aufgefallen und ich bin so auf diesen Blog gestossen.
    Stelle eben aktuell fest, das mir der Hinweis “CTRL+F5″ nicht mehr angezeigt wird, wenn ich mit dem Cursor über ein Bild fahre.
    Wer hat die gleichen Probleme?
    Ab 1.4. startet E-Plus weitere Online-Flat-Tarife und Optionen.
    Verstehe nicht, das man immer mehr Kunden versucht den Dienst anzubieten, dabei aber schon längst an technische Grenzen gestoßen ist.
    Schade, denn bin von E-Plus und dem Service bisher immer überzeugt gewesen.

  12. Hallo,

    ich gehe mit der E-Plus Datenflatrate und der Surf@home Box von O2 ins Netz.
    Dummerweise habe ich irgendwann mal die Connectionmanager für die Merlinkarte installiert. Ich denke, dabei wird irgendwas zwischen den Winsocks installiert.
    Wenn ich mit “Torpark” verschlüsselt ins Netz gehe ist das Phänomen weg.
    Jetzt könnte es natürlich sein, dass der evtl. vorgelagerte Proxy dann nicht erkennt dass es sich um Bilder handelt.

  13. Hallo,
    habe das selbe Phanomen, aber bei Vodafone. Ubrigens bin aus Dresden und DL ist so 60-70k

  14. JFischer says:

    Hallo,

    sehr interessant, habe auch gerade nach dem Problem gesucht. Setze aber eine UMTS-Karte von Vodafone ein. Ist also wohl eher ein UMTS-Feature als ein EPlus Problem. Einstellen können würde ich dieses Verhalten allerdings auch gerne…

  15. Michael Boehnke says:

    Einstellung ist per Tool möglich:

    http://www.business.vodafone.com/site/bus/public/enuk/p_software_tscs15.jsp

    Schönen Tag noch!

  16. Michael, Vielen Dank für diesen Top. Leider funktioniert der Vodafone-Client nicht mit E-Plus.

  17. Gleiches Spiel auch unter Linux (Suse10.1, Debian 3.1 usw.) Konqueror bzw. Firefox zeigen das gleiche Verhalten.
    Otmals begrenzt auch Bluetooth die Geschwindigkeit, habe hier ein Motorola E1000, welches eindeutig über BT verlangsamt wird (max. 15kbit/s), über das Datenkabel erreiche ich ca. 35kbit/s!

  18. Michael says:

    an alle die mit E-Puls oder dem E-Plus änlichen wie BASE online gehen und diese Fehlermeldung haben. So lange du die Software nutzt hast du das Problem beim Surfen auf HTML wenn du dann aber JAP installierst (Kostenlos) hast du immer die Orginalen. JAP ist ein Programm zum anonymen surfen. sofern dies überhaupt möglich ist.
    Das Programm nimmt alle deine Anfange die du stellst mit deinem Browser und setzt sie über ein anderen Port um. Somit bekommst du die ganzen HTML inhalte nicht über den E-Plus Server sondern über ein TU Server welchen du ausgewählt hast. Wenn du das ganze dann nicht mehr haben willst dann stellst du einfach bei deinen Proxy Einstellungen (Wo JAP das Automatisch Konfiguriert wenn du es eingestellt hast) localhost mit dem Port 4001 wieder aus. Dann benutzt du es nicht mehr. Man kann auch bei JAP das anonyme Surfen ausstellen aber ich mach es lieber im Bwoser so kann ich mit Zwei Browsern arbeiten, wo der eine schnell ist und der andere Orginale seiten holt.

    Viel Spaß mit der Variante und ich hoffe ihr habt damit viel spaß

  19. Holger says:

    Ich hatte das selbe Problem, benutze aber den UMTS PCMCIA Router von Linksys WRT54G3G. In diesen Router stecke ich dann meine UMTS Karte von E-Plus. Das Programm JAP funktioniert damit einwandfrei. Erstmal danke für diesen super Tipp. Der Nachteil: das ganze wird ziemlich langsam. Kennt jemand diesen Router? Kann man dort noch andere Einstellungen vornehmen damit man JAP nicht mehr benötigt? Lohnt sich die Firmware von openwrt?

  20. Holger, ein Update der Routerfirmware ist zwar möglich und bestimmt auch nicht von Nachteil, dürfte aber das angesprochene Problem nicht lösen, denn der Router ist in diesem Fall unschuldig. Es wäre nur möglich, einen anderen HTML-Proxy zu finden, der nicht so langsam ist wie JAP. Das anonymisieren ist ja nicht nötig.

  21. Michael says:

    mkarmmerer ich hab es mal mit einen von der Telekom versucht leider hatte ich das Problem mit dem E-Plus dann immer noch, deswegen war es bei mir JAP was ging. Aber vielleicht gehts am Router eher.

  22. David says:

    Dass die Bilder komprimiert stört mich eigentlich weniger.
    Dass die Geschwindigkeit andauernd schwankt und man sich nach einer agebrochenen Verbindung nichtmehr verbinden kann, ohne den PDA neuzustarten stört mich erheblich mehr

    David

  23. Klaus says:

    Ich kann glaube ich einige wieder endtäuschen: Ich nutze die BASE-Flat mit einer Vodafone-Merlin U630 an meinem Powerbook, und dafür gibt es eplus-Seitig gar keine Software, Treiber und Modemskript habe ich selber eingestellt. Trotzdem habe ich das gleiche Problem und zu allem Überfluss kan ich nicht mal mit CTRL-F5 die Seite nachladen…

    Klaus

  24. Klaus says:

    JAP hat bei mir auch keinen Unterschied gebracht, und ja, ich habe die Seite neu geladen…

  25. Sehr interessant, das alles. Ich surfe via Bluetooth und dem SE K750i auf einem MacBook Pro. Heute zum ersten Mal in Schneckengeschwindigkeit via Handy. Und da ist mir das mit den Artefakten und dem seltsamen Verhalten in Firefox aufgefallen. Und beim ersten Googlen dann diesen Blog gefunden. Tja; ich kann mit Shift+R aber zeitweise wenig ausrichten. Ich hoffe, ansonsten werden sich die Probleme in Grenzen halten.

    Ich habe mir das Ganze angeschafft, um im Sommerlager (im Wald diesmal; waynes interessiert: http://www.dpsggeldern.de für Infos) trotzdem täglich die Bilder hineinstellen zu können. Ich habe bisher gedacht, daß Firefox so intelligent sei und meint, bei langsamen Übertragungsraten einfach mal die Bilder beschneiden zu müssen. Aber das es an meinem E-Plus liegt, hätte ich nicht gedacht.

    Habe keinen Prox installiert. Werde mal ausprobieren, was die Option (“Fehlerkorrektur und Komprimierung im Modem [= Handy] aktivieren”; zu finden in den Systemeinstellungen für alle Macianer) bringt, wenn man die Deaktiviert.

  26. hi,

    es gibt noch eine andere lösung um das bilder-problem zu umgehen.
    in diesem thread stehen die verschiedenen lösungen die meisten browser.

    http://www.evdoforums.com/about1053.html

    in firefox genügt ein eintrag in “about:config”:
    string mit namen “general.useragent.override” und wert “Firefox/1.5.0.1; Blazer/4.0″.

    ein kleiner nachteil: manche webseiten reagieren darauf und stellen ihre mobilen versionen der seiten parat, so auch google. mit dem link “http://www.google.de/webhp” sieht das dann aber wieder normal aus.

  27. mac os x; eplus umts zugang; nokia e61, 45kb/s BT, aachen

    hi,

    unter mac os x geht es auch leichter und ohne dass dir diverse seiten ihre mobile-pages unterjubeln, weil wegen “blazer”.

    für safari gilt:

    1. wir schalten uns einmalig den debug modus frei
    im terminal eingeben und bestätigen:
    defaults write com.apple.Safari IncludeDebugMenu 1
    2. safari starten
    3. im menü Debug / User Agent / Konqueror 3 auswählen
    4. rumsurfen

    da ich den debug-modus auf jedem mac als erstes freischalte, gefällt die folgende lösung einfach besser. ein kurzer klick im safari und das aktive tab oder fenster surft “undercover”.

    für camino gilt:

    der camino ist so quasi der browser fürs grobe, deshalb wird hier auch die config verändert. wenn mal eine page probleme haben sollte, hab ich ja immernoch meinen safari als linux, IE oder netscape an die arbeit schicken.

    1. about:config in Adresszeile eingeben
    2. wert general.useragent.vendor suchen
    3. wert auf Trallala, Dingsbums oder xyz ändern

    firefox:

    nicht getestet, sollte aber ähnlich camino sein. wenn man nichts eingibt, was mit mobile-devices zu tun hat, kann man auch keine mobile pages sehen.

    mit dieser lösung habe ich den tollen spruch “shift+r…” bei mir beseitigt.

    gefühlt ist es jetzt aber doch ein wenig langsamer. überrascht bin ich darüber, dass es unter dem deckmantel des konqueror bei eplus funktioniert. den hat man dort wohl in der config vergessen.

  28. Guten Tag,

    spät kommt der Kommentar, aber er kommt. Vielen Dank für die Hinweise hier! Ich selbst habe mich bisher immer gewundert, woher diese Komprimierung stammt und bin nun begeistert, auf welchem einfachen Weg ich sie losgeworden bin.

    Ich dachte schon, in meiner Wettervorhersage hätte ich viel zu billige Grafiken importiert.

    Eine (fast durchgehend) sonnige Woche wünscht,

    Frank Wettert.

  29. Heiko says:

    Also, bei mir funktionieren die Tipps mit cCCLeaner und direkter Verbindung über das Startmenü leider nicht. Auch mit der about:config hatte ich bislang kein Glück. Wenn jemand mehr weiß, so möge er es bitte mitteilen.

    Nutze E-Plus/BASE mit aktueller Software (2.1) und aktuellen Firefox/Opera Versionen.

    Danke!

  30. ProfiFLOH says:

    also ich hab das Problem erst festgestellt als ich mal den Speed optimizer von o2 ausgeschaltet hatte, das mit shift+R mein ich,
    ich Depp hatte doch glatt vergessen, daß ich das deswegen installiert hatte vor nem halben Jahr, weil ich da auch rausgefunden hatte, daß die Anbieter die Frechheit besitzen einem die Bildqualität automatisch einstellen zu wollen…

    ja daraufhin konnt ich das Problem mit dem “Speed Optimizer” von O2 lösen, obwohl ich Vodafone-UMTS benutze
    Sollte also auch für Eplus gehen denk ich mal

    hoffe das hilft euch :-)

  31. Hallo zusammen,

    also ich benutze eine Merlin Karte auf einem MacBook Pro mit OS X 10.4.10 und bekomme das Problem mit den JPEGs einfach nicht in den Griff. Das mit der Komprimierung im Modem abschalten bewirkt gar nichts. Auch die Version mit dem Debug Modus in Safari usw. schafft keine Abhilfe. Irgendjemand noch eine Idee für Macuser?

  32. Ps. die Merlin ist von Vodafone und ich benutze auch die Vodafone Software

  33. Lothar Schaller says:

    Hallo Michael Boehnke, danke für den Link. Funktioniert einwandfrei.

  34. Hallo an alle,
    also ich nutze auch das Vodafone UMTS Home… Bin damit im Prinzip sehr zu frieden, hab hier in Berlin 3MBits DL-Rate und noch keine Ausfälle gehabt. Muss aber sagen, sobald man wirklich außerhalb des Bereiches ist, wirds sehr teuer je MB download.
    Ich hab hier ein süßes Programm gefunden, was auf jeden fall den D2 Leuten helfen wird. Doch vorne Weg noch eine Seite die auch o2 Leuten helfen wird: Telepolis
    für euch dürfte der Speed Optimizer Client weiterhelfen;
    für alle die bei Vodafone sind, können auf vodafone.com das Programm Bytemobile Optimization Client nutzen, iast zwar leider auf Englisch, funktioniert aber, nachdem man die Protokolloptimierung unter Advanced rausnimmt super.

  35. mrplanlos says:

    Hallo!
    Auf verzweifelten Suche nach einer Methode die Bilddarstellung zu verbessern bin ich am Ende hier gelandet. Und es ist fuer mich tatsaechlich der heilige Gral. Waehrend HTML seiten sich naemlich mit dem bereits genannten Tastenkuerzel in voller Pracht laden lassen, ist das bei Flash leider unmoeglich.
    Ich wollte nur bescheid sagen, dass die Loesung mit JAP auch in Grossbritannien mit dem Web&Walk HSDPA USB Modem von T-Online wunderbar funktioniert.
    Vielen Dank!

  36. Dennis Kennich says:

    Nutze IE7 + Firefox unter eplus (e+, e-plus) base umts. Hatte auch das leidige “Shift+R improves”-problem.

    Von mir Getestete Lösung:
    Für IE: Systemverwaltung >>> Internetoptionen >>> Sicherheit >>> Gesperrte Seiten >>> 1.2.3.4 eintragen.

    Für firefox: eingeben about:config >>> rechte Maustaste >>> new string >>> general.useragent.override >>> o.k. >>> Eintragen Firefox/2.0.0.12 oder statt 2…. die Version.
    Dann erscheint der neue String in der config. Zum Löschen >>> rechte Maustaste >>> zurücksetzen.
    Dann ist erstmal nur der Zeichen-Eintrag rechts leer. Bei erneutem Aufruf von about:config fehlt wieder der ganze Eintrag.
    Viel Erfolg bei diesem leidigen Problem. Ätzend sowas. Aber dafür gibts ja Inder, net? Kinder nett, statt Internet.

  37. Arne Peters says:

    Moin,
    ich leide unter den mickrigen Bildern und will längere Ladezeiten in Kauf nehmen!!
    Stehe aber irgendwie gerade auf der Leitung und bekomme das Problem mit keiner der aufgelisteten Lösungen in den Griff.
    Könnte sich einer erbarmen mir eine Lösung nochmal kleinschrittig zu posten???
    Ich nutze XP und den Firefox 3.0.4.

    Wäre euch sehr dankbar…

  38. Cool_Detlev says:

    Ich habe die Lösung und die ist einfacher alls ihr denkt :-)
    Geht beim Browser auf Extras/Internetoptionen/Datenschuz dort im bereich(Wählen sie eine Einstellung für den Internetzone) verschiebt ihr den balcken nach oben, von Mittel auf =!!!!!! Mittelhoch !!!!!!
    ————

  39. ich habe das selbe problem gehabt, die vodafone-hotline riet mir folgendes:
    die apn der vodafone-software soll auf folgendes geändert werden: “volume.d2gprs.de”

    die nötigen einstellungen hab ich hier veranschaulicht:
    http://www.pictureupload.de/pictures/181208174348_vodafone_umts-internet_komprimierung_deaktivieren.gif
    oder
    http://www.imgbox.de/?img=o25356v1.gif
    oder
    http://bilderupload.biz/9799059

    bei mir klappt jetzt alles einwandfrei, die bilder kommen wieder in original-qualität hier an!

  40. o2 leitet inzwischen auch über nen transparenten Proxy, was bis vor kurzem nur mit dem Speed Optimizer (alias Bytemobile Optimization Client) erreichbar war. Siehe dazu letzter Absatz http://www.o2online.de/nw/business/angebot/mobile/services/optimizer/index.html?o2_type=goto&o2_label=speedoptimizer

    Die Einstellungen können nun unter http://speedoptimizer.o2online.de/ vorgenommen werden, natürlich nur wenn man gerade mobil im o2-Netz unterwegs ist.

    Bis jetzt finde ich das ganz nett, zumal dies nun geräte- und OS-unabhängig gelöst ist.

    Frohes Fest

  41. ich hab inzwischen folgende einschränkung bemerkt:

    mit den einstellungen werden ip’s mehrfach vergeben:
    ggf. sind bestimmte dienste nicht mehr einwandfrei nutzbar!

  42. Hallo zusammen!

    Nachdem ich hier am Notebook meines Vaters auch dieses “Shift+R” Problem zum ersten mal sah (er geht via Vodafone mobil ins Netz), habe ich noch eine Moeglichkeit fuer den Firefox gefunden. Wenn man das Add-On “NoScript” verwendet (welches man sowieso haben sollte;-)), verbietet man ueber das Add-On der IP-Adresse “1.2.3.4″ die Ausfuehrung von Javascript, was dann die ungewollte Komprimierung der Grafiken unterbindet.

    MfG,
    Christian

Trackbacks

  1. Firlefonz sagt:

    E-Plus UMTS – Teil II…

    ……

  2. [...] Lösung fand ich schließlich hier (zumindest für Vodafone, meinem Anbieter) …. Nach Installation der Bytemobile [...]

Speak Your Mind

*